Как посчитать количество ячеек в Excel: формулы и не только

Друзья, в этой короткой статье я покажу вам, как можно посчитать количество заполненных ячеек в Excel. Постараюсь сделать это как всегда – коротко, понятно, по шагам. Предлагаю не рассусоливать копирайтерские введения, а просто приступить к полезному делу.

И да, чуть не забыл, если что-то осталось не понятно или просто нетрудно написать «спасибо» – добро пожаловать в комментарии.

Способ 1 – Строка состояния

Как посчитать количество ячеек в Excel: формулы и не только

Да, мало кто это знает, но строка состояния сразу показывает количество НЕПУСТЫХ выделенных ячеек (а еще там отображается и сумма, как полезное примечание). Итого все сводится к следующему:

  1. Выделяем нужную область ячеек.
  2. Смотрим на строку состояния.

Как посчитать количество ячеек в Excel: формулы и не только

Именно так все просто, и не нужно вводить никаких формул. А если вдруг у вас этого пункта почему-то нет, то щелкаем правой кнопкой мыши по любой свободной области этой строки состояния и в выпадающем меню отмечаем галочкой пункт «Количество».

Как посчитать количество ячеек в Excel: формулы и не только

Способ 2 – Формула СЧЁТЗ

Если нужно посчитать ячейки именно формулой, используем формулу СЧЁТЗ (переводим как «считай заполненные»). Пример работы формулы на скриншоте ниже:

Как посчитать количество ячеек в Excel: формулы и не только

Формула принимает или простой список ячеек или целый диапазон (как я и указал). Результат абсолютно тот же.

Можно использовать и функцию СЧЁТ (без З) – она тоже считает только заполненные ячейки, но учитывает только числа. Т.е. для нее нормальным будет выделение столбца с заголовком и текстовыми разделителями.

Способ 3 – Формула СЧЁТЕСЛИ

Еще одна популярная формула – СЧЁТЕСЛИ. Работает абсолютно также как и предыдущая (тоже считает только непустые ячейки), но дополнительно есть возможность прописать условие, по которому можно считать только те ячейки, которые например больше 10 (вторым параметром пишем “>10”). Показываю на примере:

=СЧЁТЕСЛИ(H9:H26; “>10”)

Как посчитать количество ячеек в Excel: формулы и не только

Расширенный аналог – СЧЁТЕСЛИМН (МН – много). Позволяет встроить много критериев для фильтрации счета.

Видео по теме

Автор статьи
Ботан 1047 статей
Мастер занудных текстов и технического слога. Мистер классные очки и зачётная бабочка. Дипломированный Wi-Fi специалист.
WiFiGid
Комментарии: 3
  1. Анон

    Мне как раз формула нужна была. Спасибо :idea:

  2. Миша

    Все получилось. А то документ большой вручную считать не удобно.

  3. Лена

    Спасибо тебе Ботан все ясно и понятно написано.

Добавить комментарий
После отправки комментарий может не отображаться - это нормально. Сразу же после модерации он будет опубликован. Если Вы хотите быстро узнать о получении ответа, рекомендуем оставить свой e-mail (это необязательно). E-mail используется исключительно для Вашего оповещения, мы не занимаемся спамом.

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!:

Нажимая на кнопку "Отправить комментарий", я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.